summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorGraham Northup <grissess@nexusg.org>2017-10-07 02:14:17 -0400
committerGraham Northup <grissess@nexusg.org>2017-10-07 02:14:17 -0400
commit255f0aa6de604e0bf9d37ba0ee5362ef3b9f235f (patch)
treee24314201b849746dd53f8060f48df81cd18853e /Cargo.toml
parent22dd5bc5862e91330c8da0d5f141998cdbe546fb (diff)
Graphics working
But in need of terrible refactoring. Rust is beautiful sometimes. This is not one of those times.
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 15 insertions, 2 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 26b3d60..9f0dba2 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -8,7 +8,7 @@ default = ['graphics']
# The following feature will always refer ultimately to whatever backend
# graphics library is chosen--which is subject to change.
-graphics = ['glium']
+graphics = ['glium', 'piston2d-graphics', 'piston2d-glium_graphics', 'palette']
[dependencies]
byteorder = "1.1.0"
@@ -17,6 +17,19 @@ unicode-xid = "0.1.0"
portaudio = "0.7.0"
[dependencies.glium]
-version = "0.17.1"
+#version = "0.17.1"
+git = "https://github.com/cmr/glium.git"
optional = true
features = ["glutin"]
+
+[dependencies.'piston2d-graphics']
+version = "0.22.0"
+optional = true
+
+[dependencies.'piston2d-glium_graphics']
+version = "0.43.0"
+optional = true
+
+[dependencies.palette]
+version = "0.2"
+optional = true